Skip to Store Area:

Welcome to JRRshop.com!

You have no items in your shopping cart.


You're currently on:

+ Click images to enlarge

ILIO Pulsar Patches for Spectrasonics Omnisphere 2

Email to a Friend

Be the first to review this product

Manufacturer

Availability: Immediate email delivery.

$35.00
Add Items to Cart

Quick Overview

Download License! Email Delivery!

 

Introducing a brand new collection of patches for Omnisphere 2™ with BPM-locked basses, synths, leads, pads, and FX with sounds ranging from aggressive to ethereal.

PULSAR is the latest Omnisphere 2 powerhouse patch collection from MIDIhead. As the name suggests, all of the 100+ sounds in PULSAR breathe with energetic, driving pulsations using Omnisphere 2’s extensive menu of Arpeggiators, LFOs, Envelopes, and Effects. These original patches transcend genre, providing rhythmic energy to electronic, ambient, pop, EDM and film music. Nearly all of the sounds are generated using Omnisphere 2’s DSP waveforms. Why shell out for a custom pulsing virtual instrument? Launch Omnisphere 2 and put your tracks in motion with PULSAR.

 

PULSAR focuses on the use of the modulation wheel AND aftertouch for fast, expressive, sound-altering control. Many patches are also optimized for use with The Orb, giving you even more real-time control on stage and in the studio. 

These 105 Patches Feature:

32 BPM - BASS
4 BPM - Bell
4 BPM - FX
2 BPM - LEAD
1 BPM - ORGAN
7 BPM - PAD
53 BPM - SYNTH
2 BPM - VOX 
Registered customers are entitled to free updates and bonus patches when they become available

Requires Omnisphere version 2.1 or higher. Please read the System Requirements tab for more information.

Guest Spotlight

Check out audio demos our friend Torley made for PULSAR

 

 

SYSTEM REQUIREMENTS FOR ALL USERS

• 2.4 GHz or higher processor
• 4GB RAM minimum, 8GB or more recommended
• Dual Layer compatible DVD-ROM drive
• 64GB of free hard drive space

Mac Users:

• OSX 10.8 Mountain Lion or higher
• AU, VST 2.4 or higher, RTAS/AAX capable host software
• Audio Unit plugin requires host with support for "Cocoa" based plugins
• Native 64-bit and 32-bit on OSX

Windows Users:

• VST 2.4 or higher, RTAS/AAX capable host software
• Microsoft Windows 7 and higher compatible
• Native 64-bit and 32-bit on Windows

 

You may also be interested in:
Variant1