Skip to Store Area:

Welcome to JRRshop.com!

You have no items in your shopping cart.


You're currently on:

+ Click images to enlarge

Kuassa Eve-Mp5 50''s Equalizer

Email to a Friend

Be the first to review this product

Manufacturer

Availability: Immediate email delivery.

$59.00

$29.00

Add Items to Cart

Quick Overview

Download License! Email Delivery!


INSPIRED BY THE LEGENDARY FOR THE MODERN AGE

Download License! Email Delivery!

Introducing the newest addition to the Extensive Vintage Equalizer family from Kuassa: EVE-MP5.

Kuassa EVE-MP5 is a reproduction of two of the most sought-after classic hardware equalizers, the Pultec* MEQ-5 Midrange Equalizer and the EQP-1A Program Equalizer. We drew inspiration from them and combined both EQs into a compact, single plug-in with a color coded, straightforward interface intended for fast workflows and maximum usability.

Known for their signature frequency curves, the EVE-MP5 will bring massive lows, smooth mids and shiny highs to any tracks you put them into. Utilize the famous low-end trick of boosting and attenuating the low frequencies simultaneously for a rock solid bottom-end. The MP5 is also loaded with a power amp saturation unit in the signal path. Turn it on for a hotter signal and dial the input to give a mild edge to your tracks, or push more for an overdriven sound. The “Auto” switch in the input section is useful for maintaining constant gain levels while cranking the saturation via the input knob.

 

Features:

Combination of the two Pultec* EQs into a single, compact plug-in.
Color coded knobs and straightforward interface for fast workflows.
Unique Saturation unit on the input path with automatic level compensation.
Simultaneously boost and attenuate on the same low frequency.
Distinct Pultec* natural filter curve.
Dial up large amount of boost or cut without sacrificing naturalness and musicality.

 

Compatible with: win_small mac_small ub_small vst_small vst3_logo au_small x64_small aax_small protools-compatible Propellerhead-Rack-Extension

Windows XP, Vista, 7, or Later (32/64-bit)
Mac OS 10.5 or later (32/64-bit)
VST, VST3, Audio Units or AAX compatible Host Software


Please note that this product is a plugin, a VST/VST3/AU/AAX compatible host/sequencer is needed to run this software

You may also be interested in:
Variant1